We are experiencing downtime on several of our apps
Incident Report for HarkerDev
Resolved
This incident has been resolved.
Posted Nov 05, 2019 - 16:42 PST
Investigating
We are currently investigating this issue.
Posted Nov 05, 2019 - 16:25 PST
This incident affected: HarkerDev Website, Announcements, Volunteering, Harker Pay and Bell Schedule (Backend & API).